Defrag 21 Bug Reports

Professional / Workstation / Server Edition
Antworten
tt_1111
Beiträge: 9
Registriert: So 20. Dez 2015, 18:58

Defrag 21 Bug Reports

Beitrag von tt_1111 » Fr 25. Mai 2018, 14:51

Mal wieder ein paar kleine Bugs (Defrag 21) zur Meldung an das Technik/Programmier-Team ...

(1) Die Einstellungen für 'Automatische Defragmentierung' werden (meistens) nicht mehr gespeichert. Vorgehen:

• Alle Einstellungen (obere Menüleiste).
• Reiter 'Automatische Defragmentierung'.
• Setzen der Einstellungen für ein bestimmtes Laufwerk (Haken vor dem Laufwerk).
• Klicken auf 'Übernehmen'.
• Klicken auf 'OK'.
• Nochmaliger Aufruf von 'Alle Einstellungen' -> 'Automatische Defragmentierung'

Das zuvor gewählte Laufwerk steht (außer in ganz seltenen, von mir nicht reproduzierbaren Fällen) bei allen Punkten auf deaktiviert. Dieses Spiel kann (meistens) ad infinitum fortgesetzt werden. Neustart von Defrag oder sogar des ganzen Rechners hilft in aller Regel nicht.

Als Abhilfe kann man natürlich manuell zeitgesteuerte Defrag-Jobs für alle in Frage kommenden Laufwerke definieren. Aber eigentlich sollte dieser Tab ja genau diese Arbeit abnehmen.

(2) NVMe RAID Verbunde werden nicht als SSD(s) erkannt. Ich habe aus zwei NVMe SSDs ein RAID erzeugt. O&O Defrag will dann ganz munter mit einer Standard HDD Defragmentierung loslegen, sprich: die Lebensdauer des Verbunds erheblich verkürzen. Das gleiche passierte beim Anschluss einer Standard 2.5'' Samsung SSD an einen Adaptec Controller.

Da die Diagnose, ob ein TRIM Befehl ausgeführt oder ignoriert wird, offenbar in vielen Fällen zu simpel gestrickt und nicht ausreichend ist, sollte irgendwo ein kleines Service-Menü eingebaut werden, mit der ein User die von Defrag getroffene Zuweisung des Laufwerkstyp aufheben/ändern kann. Selbst wenn kein TRIM durchgeführt werden kann, unterbliebe dann zumindest die selbstmörderische Standard-Defragmentierung mit zig Gigabyte völlig nutzlos verschobener (und somit geschriebener) Daten. Diskeeper kriegt das seit Jahr und Tag hin.

Ohne ausfallend werden zu wollen: So etwas gehört normalerweise in das Alpha- oder spätestens ins frühe Beta-Teststadium einer Software. Und Firmen, deren Entwickler ein 'Endprodukt' für derartige Versuche am User nutzen, hatten den Erfahrungen der letzten Jahrzehnte zufolge häufig mit massiven PR-/Image-Problemen zu kämpfen.

Benutzeravatar
Brigitte (O&O)
Beiträge: 609
Registriert: Mo 27. Jun 2011, 13:06

Re: Defrag 21 Bug Reports

Beitrag von Brigitte (O&O) » Fr 1. Jun 2018, 14:57

Hallo,

das unter (1) geschilderte Verhalten lässt sich hier leider nicht reproduzieren. Uns sind auch keine weiteren Meldungen dieser Art bekanntgeworden. Seit wann tritt das Problem bei Ihnen auf? Sie schreiben dass die Einstellungen "meistens" nicht mehr gespeichert werden. Es handelt sich also um ein sporadisch auftretendes Problem - wurden irgendwelche Regelmässigkeiten festgestellt unter denen es auftritt? Wurde schon eine Deinstallation von O&O Defrag 21 mit anschliessendem Neustart des Rechners und erneuter Installation von O&O Defrag 21 durchgeführt?

Das unter (2) geschilderte Phänomen eines RAID-Verbunds aus NVMe-SSD's ist nachvollziehbar, in den meisten Fällen kann der RAID-Verbund nicht mit TRIM optimiert werden, wenn die Controller/Treiber-Kombination dies nicht unterstützt:

https://docs.oo-software.com/de/oodefra ... ibility-21

Ihren Vorschlag hinsichtlich eines Service-Menüs leiten wir gerne an unsere Entwicklungsabteilung weiter.
Brigitte (O&O)

Antworten