Netzwerk Sicherung

Professional / Workstation / Server Edition
Gesperrt
KlaxMax
Beiträge: 1
Registriert: Mo 24. Aug 2015, 16:39

Netzwerk Sicherung

Beitrag von KlaxMax » Mo 24. Aug 2015, 16:46

Guten Tag,

ich möchte meinen PC mit DiskImage 10 im Netzwerk (FreeNas Server) Sichern.
Der Windows 10 PC hat leise/schreib Rechte am NAS-Server (Freigegebenen Ordner) ...
... leider erscheint folgende Fehlermeldung:

{Falscher Typ}
Es besteht ein Widerspruch zwischen dem für den Vorgang verlangten Objekttyp und dem angegebenen Objekttyp.

Jemand eine Idee?
Lg, Max

Benutzeravatar
Brigitte (O&O)
Beiträge: 719
Registriert: Mo 27. Jun 2011, 13:06

Re: Netzwerk Sicherung

Beitrag von Brigitte (O&O) » Di 25. Aug 2015, 08:40

Hallo KlaxMax,

die Sicherung auf ein NAS mittels O&O DiskImage 10 ist grundsätzlich möglich. Bitte beachten Sie daß für das Schreiben auf das NAS die Authentifizierungsinformationen unter Start -> Programmeinstellungen -> Sicherheit hinterlegt sein müssen. Falls dies noch nicht der Fall ist, fügen Sie diese bitte hinzu. Führen Sie dann über O&O DiskImage den Lese-/Schreibtest auf das NAS durch, dieser muß erfolgreich sein.

Weitere Informationen zur Sicherung ins Netzwerk finden Sie hier:

http://docs.oo-software.com/de/oodiskim ... werk-2-2-2
Brigitte (O&O)

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Sa 12. Sep 2015, 14:24

Hallo zusammen,

ich muss mich meinem Vorschreiber anschließen: seit dem Update auf die aktuelle Version bekomme ich mit O&O DiskImage auch keine Verbindung zu meinem QNAP NAS mehr zustande. Dass ich das Kennwort richtig eingegeben habe, bin ich mir sicher, denn es ist derselbe User Account, mit dem ich mich an meinem Rechner anmelde und mit dem ich von dort aus Freigaben der QNAP verbinde.

Die in Ihrem Link beschriebenen Schritte funktionieren leider nicht, denn genau an der Stelle, an der ich die Authentisierungsdaten hinterlegt habe, erscheint ja der Fehler, dass kein lesender/schreibender Zugriff möglich ist. Wenn ich genau dieselben Werte in eine Shell schreibe und mit "net use" das Share verbinde, funktioniert dies ohne Probleme und ich kann auch Daten darauf schreiben.
Ich habe bei der Einrichtung der Credentials in O&O auch mehrere Schreibvarianten ausprobiert: user; nas\user; user@nas aber nichts war zielführend.

Auch bei mir hat die Vorgängerversion ohne Probleme funktioniert und erst die neue Version oder Windows 10 macht an dieser Stelle Probleme. Schade, dass bei jeder neuen O&O DiskImage Version irgendwas nicht mehr funktioniert, das bei den Vorgängerversionen problemlos gelaufen ist. :?

Grüße

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Sa 12. Sep 2015, 14:35

Nachtrag: wie bereits an anderer Stelle im Forum beschrieben, läuft bei der Authentisierung von DiskImage etwas schief. DiskImage meldet sich nicht mit dem Benutzer, der im Passwort Safe hinterlegt wurde an, sondern mit "guest". Und dieser User hat, schon aus Sicherheitsgründen, auf dem Backup Share keine Rechte.
QNAP Logins.jpg

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Sa 12. Sep 2015, 14:56

Und noch ein Nachtrag: ich habe jetzt nochmal ein wenig Fehlersuche betrieben.

Wenn ich DiskImage 10 auf einem Windows 7 Rechner installiere, funktioniert die Authentisierung am NAS und wenn ich DiskImage 10 auf einem Windows 10 Rechner installiere schlägt sie fehl.

Beide Windows Installationen sind komplett neu, ohne weitere Anwendungssoftware. So wie sich das darstellt, sollte sich O&O Software nochmal mit DiskImage und dem Zugriff auf SAMBA Shares unter Windows 10 befassen.

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Netzwerk Sicherung

Beitrag von Martin (O&O) » Mo 14. Sep 2015, 08:57

Hallo mgrabo,

möglicherweise erwartet das QNAP Gerät eine andere Form der Eingabe wie z.B.: Domain\username

Hier mögliche Beispiele für Benutzername:

IHRCOMPUTERNAME\BENUTZERNAME
QNAP\BENUTZERNAME
IHRCOMPUTERNAME\admin
QNAP\admin

mit dem jeweils korrekten Passwort. (Benutzername und Computername bitte entsprechend anpassen)


Versuchen Sie es auch mit den Standard-Credentials von QNAP:
Default user name: admin oder qnap\admin
Password: admin


Martin (O&O)

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Mo 14. Sep 2015, 10:29

Hallo Martin,

das habe ich alles schon durchprobiert, das Admin Kennwort habe ich auf einen anderen Wert gesetzt.

Es ist nicht die QNAP, denn unter Windows 7 funktioniert die Anmeldung und die Sicherung ohne Probleme. Nur in der Kombination O&O DiskImage 9 oder 10 mit Windows 10 tritt der Fehler auf.

Auch wenn ich beim Share den Gastzugriff mit vollen Rechten aktiviere, schlägt die Authentisierung fehl. Aber eine Anmeldung als GUEST lasse ich auf der QNAP auf keinen Fall zu. Zu diesem Zweck habe ich einen separaten Benutzeraccount, der ausschließlich auf das Backup Share kommt.

Ich setze O&O DiskImage auf der QNAP seit zwei Jahren ein und erst seit der Migration auf Windows 10 ist die Authentisierung nicht mehr möglich. An der QNAP Konfiguration hat sich nichts geändert und wenn ich eine Demo von DiskImage 10 in einer Windows 7 VM installiere, funktioniert die Authentisierung. Tue ich dasselbe in einer Windows 10 VM, schlägt sie fehl. Auf beiden VMs bin ich aber in der Lage, mit einem net use und Benutzername in der Form QNAP\backup eine Verbindung zum Share herzustellen. Von daher kann ich sagen: die Angabe des Benutzers hat in dieser Notation unter DiskImage (Windows 7) und in der Kommandozeile (Windows 7 und Windows 10) funktioniert.

Haben Sie noch einen Plan B? Ich habe mir im Juli das Update auf die aktuelle Version geholt, weil ich davon ausgegangen bin, dass diese volle Windows 10 Kompatibilität bereitstellt.

Grüße
Michael

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Netzwerk Sicherung

Beitrag von Martin (O&O) » Mo 14. Sep 2015, 11:33

Hallo Michael,

ich leite das Ganze an unsere Entwickler weiter, frage aber zur Sicherheit nochmal nach: Hatte Sie beim hinterlegten Benutzernamen (in DiskImage) die Kombination Domain\Benutzer getestet? (IHRCOMPUTERNAME\BENUTZERNAME bzw. QNAP\BENUTZERNAME)

Fall das QNAP Gerät umbenannt ist probieren Sie es auch mit QNAPGERÄTENAME\BENUTZERNAME
(entsprechend anpassen)

Martin (O&O)

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Mo 14. Sep 2015, 13:16

Hallo Martin,

ich hatte das mit QNAP-1\user ausprobiert. Eine Domäne nutze ich nicht und QNAP-1 ist der Gerätename, der in der Konfiguration hinterlegt ist.
Und diese Kombination hat unter Windows 7 auch funktioniert.

Was ich zusätzlich versucht habe: in der Windows Accountverwaltung habe ich die Credentials des QNAP Shares auch hinterlegt, weil ich mir nicht sicher war, ob das vielleicht das Problem ist.
Und ich habe in der lokalen Policy aktiviert, dass Kennwörter mit umkehrbarer Verschlüsselung gespeichert werden, denn auch das hatte in früheren Jahren mit Samba Probleme gemacht.

Vielen Dank, wenn Sie das an die Entwickler weiterleiten. Sollten Sie noch weitere Informationen benötigen, liefere ich die gerne nach. Ich bin Informatik Ingenier, das sollte also eher kein Problem sein.

Grüße
Michael

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Netzwerk Sicherung

Beitrag von Martin (O&O) » Mo 14. Sep 2015, 15:20

Hallo Michael,

leider lässt sich das Problem hier unter Windows 10 auf einem QNAP nicht reproduzieren:
QNAP_Test.PNG
Ein Zugriff ist auf die Freigabe direkt möglich nachdem diese in DiskImage hinterlegt wurde.

In den Privilegieneinstellungen des QNAPs hat der verwendete Benutzer "RW" Rechte auf den Ordner und der Ordner ist in DiskImage als UNC Pfad hinterlegt.

Bitte stellen Sie sicher dass innerhalb der Authentifizierung in DiskImage der Zielordner nach folgendem Muster hinterlegt ist
O&O DiskImage unter "Programmeinstellungen" -> Sicherheit:
Netzwerkpfad: \\qnas\zielordner
Benutzername: oodi
Passwort: ******

Stellen Sie außerdem sicher dass Sie bei der Imageerstellung den entsprechenden Zielpfad, hier \\qnas\zielordner\sicherungsdatei.omg
verwenden und nicht etwa einen gemappten Laufwerksbuchstaben.

Martin (O&O)

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Mo 14. Sep 2015, 18:23

Hallo Martin,

das ist ja echt merkwürdig. Ich habe jetzt auch mal eine Reihe von Screenshots angehängt, wie das bei mir aussieht. Denn die Settings, so wie ich sie eingetragen habe, funktionieren unter Windows 7 problemlos und sehen eigentlich in Ordnung aus.

So ist das Share im Passwort Safe eingetragen:
OODI-Passwort Safe.jpg
OODI-Passwort Safe.jpg (32.43 KiB) 9414 mal betrachtet
Über diesen Weg prüfe ich den Zugriff:
OODI-Zugriffsrechte prüfen.jpg
OODI-Zugriffsrechte prüfen.jpg (36.71 KiB) 9414 mal betrachtet
Was dann leider mit der Fehlermeldung 0xc00000c3 quittiert wird:
OODI-Ergebnis.jpg
Der Zugriff auf das Share über den Windows Explorer mit meinem User funktioniert ohne Probleme. Und ich habe zum Testen denselben User verwendet, mit dem ich mich an Windows anmelde. Das Passwort habe ich ohne * eingetragen, sondern mit im Klartext anzeigen lassen, um Probleme, wie beispielsweise ein englisches Keyboardlayout oder prellende Tasten auszuschließen.
Windows Explorer.jpg
Und ich die Aufgabe habe ich nochmal kontrolliert, um sicher zu gehen, dass dort auch wirklich das korrekte Share eingetragen ist. Wenn ich den dort angegebenen Pfad in den Explorer kopiere, lande ich in diesem Verzeichnis.
OODI-Aufgabe.jpg
Ich bin jetzt ein klein wenig ratlos, was die Ursache sein könnte. Ich habe dieses Verhalten jetzt auf drei Rechnern mit Windows 10 nachvollzogen: mein Deskside, mein Laptop und eine Windows 10 VM. Die ersten beiden Systeme sind ein Upgrade von Windows 7 während in der VM eine Insider Preview läuft, die frisch installiert ist.
Haben Sie in einer Windows Domäne getestet, in der eventuell zentral irgendwelche Sicherheitseinstellungen gesetzt sind, die meinem Client fehlen? Gibt es die Möglichkeit, im Detail mitzuprotokollieren, was OODI denn treibt, wenn es die Verbindung zum Share aufbaut?

Grüße
Michael

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Mo 14. Sep 2015, 20:27

Nachtrag: ich hab jetzt mal mit den Sysinternal Tools geschaut, ob ich rausbekomme, was da eigentlich abgeht. OODI und die QNAP scheinen sich zuerst tatsächlich mit SMB2 zu unterhalten. Aber irgendwann kommt einer von beiden auf die Idee, statt dessen lieber WebDAV zu verwenden.

Auf jeden Fall versucht OODI auch, die Test-Datei per WebDAV zu erzeugen. Das ist einer der letzten Einträge, bevor dann auch die Fehlermeldung erscheint.
WebDAV.jpg

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Netzwerk Sicherung

Beitrag von Martin (O&O) » Fr 18. Sep 2015, 14:14

Hallo Michael,

von O&O DiskImage aus wird keine WebDAV Verbindung aufgebaut. Die komplette Kommunikation läuft direkt über die dafür vorgesehene Windows-API. Wir haben derzeit keinen weiteren Anhaltspunkt warum dies bei Ihnen auf dem NAS nicht funktioniert.

Martin (O&O)

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Fr 18. Sep 2015, 15:14

Hallo Martin,

das hört sich erstmal nicht gut an.

Ich habe mal die Prüfung mit Acronis True Image 2016 gemacht. Dort bin ich in der Lage, auf meinem NAS Images zu erzeugen.

Was machen wir denn jetzt? Im Moment habe ich Geld für eine Anwendung ausgegeben, die ich in seit dem Windows 10 Upgrade nicht mehr nutzen kann. Wie ja schon mehrfach geschrieben: unter Windows 7 ist die Funktionalität gegeben und ich kann das mit drei Windows 10 Maschinen reproduzieren.

Um ehrlich zu sein: ich bin unzufrieden, wenn das der abschließende Stand ist.

Grüße
Michael

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Netzwerk Sicherung

Beitrag von Martin (O&O) » Mo 21. Sep 2015, 08:47

Hallo Michael,

da sich das Problem bei uns unter Windows 10 nicht nachstellen lässt müssen derzeit davon ausgehen dass irgendetwas an Ihrer Konfiguration das Problem verursacht.
Innerhalb unserer Zufriedenheitsgarantie haben Sie bis zu 30 Tagen ein Rückgaberecht über unseren OnlineShop.

Martin (O&O)

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Netzwerk Sicherung

Beitrag von Martin (O&O) » Fr 6. Nov 2015, 13:58

Hallo Michael,

bei einer weiteren Recherche sind wir auf folgenden Thread aufmerksam geworden:

http://forum.qnap.com/viewtopic.php?t=112857

Es sieht so aus als ob Windows 10 Probleme mit der Kommunikation via SMB hat, bzw. sich mit dem QNAP via SMB2/SMB2.1 nicht verständigen kann.
Als Workaround scheint das Umstellen des QNAPS auf SMB1 zu funktionieren.


Martin (O&O)

mgrabo
Beiträge: 11
Registriert: Sa 12. Sep 2015, 14:17

Re: Netzwerk Sicherung

Beitrag von mgrabo » Mo 23. Nov 2015, 12:32

Hallo Martin,

vielen Dank für die Info. Ein Wechsel auf SMB1 würde leider an anderer Stelle Probleme aufwerfen: ich nutze den Windows Client Side Cache und der wiederum benötigt, soweit ich weiss, mindestens SMB2.

Ich habe in der Zwischenzeit auch Ihr Angebot angenommen, mein O&O DiskImage zurückzugeben und verwendet nun ein Produkt der Konkurrenz. Und das kann problemlos auf die QNAP zugreifen und Images erstellen.

Neben diesem Fehler, der für mich letztendlich das K.O. Kriterium war, hat O&O die Pflege der Software in den letzten Jahren an vielen Stellen vernachlässigt. Teilweise sind Einstellungen in den Jobs nur manuell durch Anpassung der zugehörigen XML Files möglich, weil die entsprechenden Optionen in der Oberfläche fehlen. O&O weiss um dieses Verhalten und behebt das einfach nicht. Haben Sie schonmal versucht, die Ausschlussliste in einem angelegten Job zu ändern? Oder das Verhalten, wenn bereits eine Image Datei vorhanden ist?

Viele Grüße
Michael

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Netzwerk Sicherung

Beitrag von Martin (O&O) » Mo 23. Nov 2015, 13:25

Hallo Michael,

wenn die Sicherungsaufgabe bereits vorhanden ist dann lassen sich solche Anpassungen in der Tat nur manuell durch Änderung der XML Datei umsetzen. Ich leite Ihre Hinweise an die Kollegen weiter.

Martin (O&O)

Gesperrt