Win 10 Bachups funktinieren bei DiskImage 9+10 nicht

Professional / Workstation / Server Edition
Gesperrt
freiwillig
Beiträge: 19
Registriert: Do 27. Aug 2015, 05:43

Win 10 Bachups funktinieren bei DiskImage 9+10 nicht

Beitrag von freiwillig » Do 27. Aug 2015, 06:16

Hallo,

Ich habe ein Problem mit den Backups von Windows 10.

Bei der installation von Windows 8.1 werden bei UEFI insgesamt 4 Laufwerke eingerichtet.
Ein 300MB, 128MB, 450MB und Laufwerk C
Bei Windows 10 werden auch 4 Laufwerke eingerichtet.
Nur mit dem unterschied, das das Laufwerk mit 128MB nur noch 16MB hat.
Windows 10 funktioniert zwar einwandfrei und es lässt sich auch ein Backup einrichten.
Nur das Rückspielen von diesem Backup geht nicht und es kommt die Meldung,

Einem Dienst oder einer Funktion wurde ein ungültiger Parameter übergeben.

Jetzt habe ich Windows 10 neu installiert, wobei ich Windows 8.1 zu erst installiert und danach
eben das Windows 10 Update gemacht habe.
Damit eben das Laufwerk mit 16MB auf 128MB kommt.

Meine Frage wäre, wie kann man es abstellen, bzw. wie kann man Windows 10 installieren und das Laufwerk
hat 128MB.

Danke für etwaige Antworten

MfG

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Win 10 Bachups funktinieren bei DiskImage 9+10 nicht

Beitrag von Martin (O&O) » Fr 28. Aug 2015, 10:49

Hallo freiwillig,

seit Windows 10 wurde von Microsoft die Größe der MSR Partition auf 16MB geändert:
https://msdn.microsoft.com/en-us/librar ... s.85).aspx

Eine entsprechende Anpassung in DiskImage soll in den nächsten Wochen zur Verfügung stehen.


Um die MSR als 128MB auf einer neuen und leeren Festplatte anzulegen können Sie die in DiskImage integrierte Eingabeaufforderung (der BootCD) verwenden:
1. O&O DiskImage Start-CD booten
2. Eingabeaufforderung öffen (unter Werkzeuge)
3. Diskpart öffnen

Zielfestplatte identifizieren und als GPT initialisieren, in Diskpart dafür wie folgt vorgehen:

list disk
um die Liste der Datenträger anzuzeigen

richtige Zielfestplatte identifizieren, hier im Beispiel Disk 0

sel disk 0
um die Disk 0 zu wählen

clean
Datenträger wird damit gelöscht

convert gpt
Datenträger wird als GPT initialisiert

create partition efi size=100
EFI Systempartition wird mit 100MB erstellt

create partition msr size=128
MSR Partition wird mit 128MB angelegt

exit
Diskpart wird geschlossen

Danach innerhalb der O&O DiskImage Oberfläche mit F5 die Laufwerke neu einlesen lassen.

Bei der folgenden Wiederherstellung bitte die Partitionen (z.B. EFI, MSR und C) nacheinander separat wieder herstellen:

Quelle "EFI Partition" auf die soeben mit Diskpart erstellte EFI zuordnen und wiederherstellen (sektorbasiert)
danach
Quelle "MSR" auf die mit Diskpart erstellte MSR zuordnen und wiederherstellen (sektorbasiert)
danach
"C" Partition auf leeren Bereich hinter den bereits wiederhergestellten "EFI" und "MSR" zuordnen und wiederherstellen (dateibasiert sofern eine Größenanpassung notwendig ist, z.B. wg. kleinerer Zielfestplatte)


Martin (O&O)

freiwillig
Beiträge: 19
Registriert: Do 27. Aug 2015, 05:43

Re: Win 10 Bachups funktinieren bei DiskImage 9+10 nicht

Beitrag von freiwillig » Fr 28. Aug 2015, 22:16

Hallo, Martin

Danke für Deine Antwort und Beschreibung und hoffe, das die geänderte Version
bald zur Verfügung steht.
Deine Beschreibung ist soweit ok, wobei ich anmerken möchte,
wenn man die 128 MB Partition angelegt hat, diese nicht zu formatieren, da sie dann 124 MB anzeigt ( bei mir jedenfalls ) .
Also einfach anlegen und so belassen und keinen LW Buchstaben hinzufügen.

MfG

PS : wie erfahre ich, wenn die geänderte Version zwecks download heraus gekommen ist ?

freiwillig
Beiträge: 19
Registriert: Do 27. Aug 2015, 05:43

Re: Win 10 Bachups funktinieren bei DiskImage 9+10 nicht

Beitrag von freiwillig » Sa 29. Aug 2015, 13:17

Hallo, Martin

Ich habe heute Vormittag das ganze noch einmal durch gespielt und Windows 10
neu installiert.
Wobei ich einen USB Stick als Startmedium DI 9 benutzt habe, wegen besagten 128 MB .
Während der Installation habe ich eine Partition von 128 MB angelegt,
sodass es 5 LW ergibt :
450 MB = Wiederherstellung
100 MB = System
16 MB = MRS
128 MB = ohne Bezeichnung
und danach eben LW C:

Danach habe ich mit DI 10 ein Image angelegt und es wieder zurück gespielt.
Leider hat es alles nicht auf einmal eingespielt.
Ich habe dann die einzelnen LW überspielt und es hat funktioniert.
Danach habe ich alle Treiber und Programme, mit denen ich arbeite, installiert und davon ein DI angelegt.
Wiederum habe ich die LW einzeln auf eine andere FP überspielt und es hat voll funktioniert.

ich hoffe, das ich dem einen oder anderen helfen konnte

MfG

Benutzeravatar
Martin (O&O)
Beiträge: 874
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Win 10 Bachups funktinieren bei DiskImage 9+10 nicht

Beitrag von Martin (O&O) » Mo 31. Aug 2015, 11:41

Hallo,

am sichersten ist es derzeit die Partitionen manuell - wie oben von mir beschrieben - anzulegen und die Wiederherstellung dann schrittweise
auszuführen.
BTW: Es reicht diese anzulegen, formatieren ist nicht notwendig bzw. wie bei der MSR gar nicht vorgesehen.

Martin (O&O)

Gesperrt