Bootmedium macht bei 4K Monitor Probleme

Professional / Workstation / Server Edition
Antworten
Herbert55
Beiträge: 1
Registriert: Fr 23. Nov 2018, 08:57

Bootmedium macht bei 4K Monitor Probleme

Beitrag von Herbert55 » Fr 23. Nov 2018, 09:23

Das neue DiskImage 14 macht wie alle Versionen davor Probleme beim BootMedium. Benutzt man zur Erstellung des Bootmediums einen Rechner mit FullHD Auflösung oder höher wird die Oberfläche der Software 1. kleiner und 2. teils nicht mehr lesbar. Das geht soweit dass die Icons ganz nach oben links rutschen, winzig sind und nicht mehr lesbar (4K). Klickt man im Verdacht auf eines der beiden Icons erscheint eine Seite auf der in der Mitte ein kleines Rechteck mit den einzelnen Funktionen der Software erscheint, nur ist hier der Text unterbrochen, nicht mehr lesbar. Das Problem ist wohl die Auflösung. Ich habe auch schon versucht einen Standard VGA Treiber zu laden wie vom Support empfohlen. Dies wird jedoch vom Programm abgebrochen mit dem Hinweis dass der Treiber für diese Version nicht gemacht ist. Würde man von Seiten der Programmierer die Software so programmieren dass die Seite komplett ausgefüllt ist mit entsprechend großen Feldern und Beschriftungen, dann müsste das auch bei 4K noch sichtbar sein. So wie es jetzt ist hat man nur einen großen breiten grauen Rand. Das Problem liegt wohl bei Windows PE wie mir der Support sagte. Doch das scheint mir nur ein Teil der Wahrheit zu sein. Betrachtet man beim Paragon Festplattenmanager 16.5 die ebenfalls unter 4K erstellte Windows PE Boot CD so stellt man schnell fest dass es dort funktioniert und man kann mit der Maus bei Bedarf die Fenster vergrößern oder verkleinern, damit alles lesbar ist. Hier scheint mir eine schnelle Lösung geboten da bei Totalausfall des Rechners das Bootmedium extrem wichtig ist und da selbst billig Notebooks schon HD Auflösung haben. Löst man bei O&O dieses Problem nicht werden potentielle Kunden abspringen. Nicht jeder Kunde ist so versiert dass er eine BootCD mit VGA Treiber erstellen kann und nicht jeder hat dazu einen alten Rechner mit dieser Auflösung. Das Einbinden des Treibers über die *.inf Datei funktioniert nicht. Ich habe alle Varianten ausprobiert.
Das Problem tritt natürlich bei den anderen O&O Programmen mit WinPE BootCD genauso auf. Es ist kein typisches DiskImage Problem.

Benutzeravatar
Nemo_G
Beiträge: 6
Registriert: Fr 21. Feb 2014, 22:10

Re: Bootmedium macht bei 4K Monitor Probleme

Beitrag von Nemo_G » Sa 24. Nov 2018, 19:51

Das Problem meines Vorredners muss ich leider bestätigen, nachdem ich einem Freund ebenfalls einen Rechner (Lenovo Thinkpad P71) mit einem hochauflösenden 4k-Display eingerichtet habe.
Dieselben fuzzeligen Ansichten wie beim Bootmedium von OODI traten auch bei Adobes Creative Suite (PhotoShop & Co) auf.
Ein funktionierender Lösungsansatz wird unter "Adobe App Scaling on High DPI Displays (FIX)" von Dan Antonielli beschrieben.

Das Verfahren habe ich auf die Boot.wim im Bootmedium von OODI 12 angewendet:
  • Die dort bereitgestelle *.manifest habe ich als oodipro.exe.manifest neben die %ProgramFiles%\OO Software\DiskImage\oodipro.exe gestellt.
    manifest.zip
    Archiv mit oodipro.exe.manifest
    (643 Bytes) 30-mal heruntergeladen
  • In die SystemStart.bat habe ich den beschriebenen Reg-Eintrag in der Registry eingefügt

    Code: Alles auswählen

    @ECHO off
    
    IF EXIST "%ProgramFiles%\OO Software\DiskImage\oodiagpsWin32.dll" ( 
    	regsvr32 "%ProgramFiles%\OO Software\DiskImage\oodiagpsWin32.dll" /s
    )
    IF EXIST "%ProgramFiles%\OO Software\DiskImage\oodiagpsx64.dll" (
    	regsvr32 "%ProgramFiles%\OO Software\DiskImage\oodiagpsx64.dll" /s
    )
    
    ::PreferManifst
    REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide" /f /v PreferExternalManifest /t REG_DWORD /d 1
    
    "%ProgramFiles%\OO Software\DiskImage\oodiag.exe" /service
    REM zur Sicherheit
    net start "OO DiskImage"
    "%SYSTEMDRIVE%\Program Files\OO Software\DiskImage\oodipro.exe"
    
Leider war die Modifikation nicht erfolgreich: Es wurde beim Starten die nicht passende oodipro.exe.manifest bemängelt.

Aber vielleicht wäre das ein Ansatz, dem die Entwickler von O&O nachgehen sollten, um per angepasster *.manifest für eine ordentliche Darstellung auch auf 4k-Monitoren zu sorgen.

Gruß, Nemo

Benutzeravatar
Brigitte (O&O)
Beiträge: 680
Registriert: Mo 27. Jun 2011, 13:06

Re: Bootmedium macht bei 4K Monitor Probleme

Beitrag von Brigitte (O&O) » Do 29. Nov 2018, 12:17

Hallo,

unsere Entwickler sind an dem Problem dran, sorry!
Brigitte (O&O)

Benutzeravatar
Nemo_G
Beiträge: 6
Registriert: Fr 21. Feb 2014, 22:10

Re: Bootmedium macht bei 4K Monitor Probleme

Beitrag von Nemo_G » Do 29. Nov 2018, 15:40

Brigitte (O&O) hat geschrieben:
Do 29. Nov 2018, 12:17
... unsere Entwickler sind an dem Problem dran, sorry!
Seien Sie bitte darüber nicht traurig, aber geben Sie ein Feedback, wenn das Problem gelöst wurde; möglichst auch bei OODI 12.

Gruß, Nemo

Benutzeravatar
randybonnette
Beiträge: 1
Registriert: Fr 21. Jun 2019, 13:13

Re: Bootmedium macht bei 4K Monitor Probleme

Beitrag von randybonnette » Mo 24. Jun 2019, 07:13

Brigitte (O&O) hat geschrieben: ↑
writemyessay... unsere Entwickler sind an dem Problem dran, sorry!
Neuigkeiten oder Updates dazu? Ich suche den Leitfaden zu den Unterschieden zwischen der Option "System" und "System (Enhanced)" für die DPI-Skalierung.
Die CS6-Apps scheinen mit „System (Enhanced)“ besser auszusehen.

Antworten