Lokale Installation über die EMC

Die Netzwerk-Console für O&O Defrag und O&O DiskImage.
Antworten
th32to
Beiträge: 6
Registriert: Do 21. Feb 2013, 09:34

Lokale Installation über die EMC

Beitrag von th32to » Do 28. Feb 2013, 23:02

Hallo O&O,

mit mehreren verschiedenen Installationsvarianten habe ich die EMC jetzt schon benutzt. Aber ein Problem konnte ich bisher nicht lösen:
Wie installiere ich die Produkte lokal, also auf dem Wirt der EMC?
Ich bin bisher immer von einer unberührten Betriebssystemvariante ausgegangen. Kein Customizing keine GPO, keine Registryänderung.
Ein ganz jungfräuliches System. Grundsätzlich war jedoch eine Domäne mit im Spiel. Zu keiner Zeit habe ich einen Server ohne Domäne eingesetzt. Allerdings habe ich immer noch .NET nachgereicht, wie gefordert.
Anschließend habe ich immer eine (1) Gruppenrichtline erzeugt, welche die benötigten Ports auf der Firewall aufmacht.
Diese wird auch anstandslos (auch auf den Wirt) übertragen.
In meinem Szenario, welches aktuell läuft, habe ich (wie im anderen Post schon geschrieben) Windows Server 2012 Essentials laufen und als "Client" jeweils Windows 8, 7 und Server 2008 R2. Für das Szenario ist es egal ob ich die 2012 oder 2011 Variante des Essentials Servers verwende. Auch spielt es keine Rolle, ob ich Essentials, Standard, Enterprise oder Datacenter verwende.
Als Installer-User wird ein User verwendet, der Mitglied der Domänen-Admins ist. Dies ist auch seine Primäre Gruppe. Eine eventuelle Benutzergruppe habe ich entfernt, das hatte jedoch keinen Effekt. Wahlweise habe ich den von mir auch zum interaktiven anmelden verwendeten Domänen-Admin benutzt, alternativ aber auch einen dedizierten mit gleichen Rechten. Wahlweise habe ich auch den Dienst Sekundäre Anmeldung aktiviert.
Das Phänomen ist immer gleich.
Auf allen Clients (auch den Server) kann ich problemlos Tools installieren, planen, kontrollieren und deinstallieren.
Nur auf dem Wirt gelingt das nicht.
Die Fehlermeldungen sind (abhängig vom Retry-Level und unkontrollierbar gemischt)
- 1603
- MSI Event missing
- komplettes Aufhängen des Dienstes über Stunden
- 1719

Alles dabei. Aber keine lokal Installation.

Klar kann ich schummeln und die Tools manuell installieren. Dann kann ich sie auch über die EMC steuern.
Aber deinstallieren z.B. geht auch nicht.

Preisfrage:
Was nehmen Sie bei O&O für Änderungen in der Registry, Gruppenrichtlinien o.ä, am Wirt vor, das es funktioniert.

Grüße
Thorsten Schmidt

Benutzeravatar
Brigitte (O&O)
Beiträge: 625
Registriert: Mo 27. Jun 2011, 13:06

Re: Lokale Installation über die EMC

Beitrag von Brigitte (O&O) » Fr 1. Mär 2013, 15:49

Hallo Herr Schmidt,

ein generelles Problem ist uns leider nicht bekannt. Die Remoteinstallation über die EMC ist normalerweise auf dem EMC-Server problemlos möglich. Bitte senden Sie die Logdateien der EMC an den technischen Support (support@oo-software.com) unter Verweis auf Ihren Eintrag im Forum. Die Logdateien finden Sie hier:

C:\ProgramData\OO Software\OO Enterprise Management Console\4.0

bzw.

C:\ProgramData\OO Software\OO Enterprise Management Console Service\4.0

Packen Sie am einfachsten die beiden Verzeichnisse mit 7zip oder einem ähnlichen Tool und senden uns die Dateien im Anhang an Ihre Email zu.

Brigitte (O&O)
Brigitte (O&O)

th32to
Beiträge: 6
Registriert: Do 21. Feb 2013, 09:34

Re: Lokale Installation über die EMC

Beitrag von th32to » So 3. Mär 2013, 23:16

Hallo Brigitte,

ich habe die ein oder andere Stunde des Wochenendes in das Thema investiert und bin jetzt an dem Punkt wo ich recht klar sagen kann, das ich das Problem zuverlässig reproduzieren kann, wenn der Steuerungsdienst inklusive der DB (2005 oder 2008, welche ist egal) auf einem Domänen-Controller läuft. Alle anderen Varianten mit oder ohne Domäne funktionieren, wenn man auch hin und wieder über eine GPO eingreifen muss, um dem User zum installieren ein paar Freiheiten zu geben.

Bei einer Nutzung eines SBS oder Essentials-Servers ist die problematische Variante jedoch nicht zu umgehen. Und nur für die EMC eine weitere physische Maschine aufzubauen ist Overkill.

Ich werde jetzt mal von den VMs auf einen physische Maschine in einem getrennten VLAN wechseln.
Dann schicke ich Logs.

Grüße
Thorsten Schmidt

044hnoor
Beiträge: 1
Registriert: Mi 25. Feb 2015, 13:01

Re: Lokale Installation über die EMC

Beitrag von 044hnoor » Mi 25. Feb 2015, 13:04

Klar kann ich schummeln und die Tools manuell installieren. Dann kann ich sie auch über die EMC steuern.
Aber deinstallieren z.B. geht auch nicht.
Unlock the key of your success by Testking mcat practice test and [rhce certification By using our latest passguide and ju study Southern California Institute of Architecture you can easily pass selftestengine exam.

th32to
Beiträge: 6
Registriert: Do 21. Feb 2013, 09:34

Re: Lokale Installation über die EMC

Beitrag von th32to » Mi 25. Feb 2015, 13:20

Genau so isses.

Die einzige Chance das in den Griff zu bekommen ist es, in der Registry den String zu ändern, der für msiexec verwendet wird und dort als Parameter "-a" einzugeben. Anschließend müssen alle User Permissions auf "frag mich bloss nicht und mach einfach" geändert werden. Zu guter Letzt müssen per GPO noch alle msiexec GPO auf "mach alles mit höchstmöglichen Rechten" gestellt werden.
Wenn man das gemacht hat, muß man die EMC noch mit einem User starten, der sowohl Domänen-Admin ist, als auch noch als primäres Profil Domänen-Admin ist. Danach läuft jedoch das Dashboard nicht mehr korrekt.

Dann....und nur dann......kann man über die EMC die Pakete auch auf den lokalen Domänen-Controller verteilen.

Würde O&O die Pakete nicht als msi sondern als exe verteilen gäbs den ganzen Zeck nicht und alles funktioniert.
O&O msi's werden auf Domänen-Controllern (vermutlich durch die fehlenden Zertifikate) als höchst unsicher eingestuft.....was ja auch korrekt ist.

So gesehen ist die EMC wirklich ein schwaches Produkt.

th32to
Beiträge: 6
Registriert: Do 21. Feb 2013, 09:34

Re: Lokale Installation über die EMC

Beitrag von th32to » Mi 25. Feb 2015, 13:31

Kleiner Nachtrag:

Ich habe jedoch aufgehört, mich darum zu kümmern, da O&O an der grundsätzlichen Struktur der EMC anscheinend nichts ändern will und das Produkt gerade eh einschlafen lässt.
Anders ist es für mich nicht zu erklären, warum es seit fast 8 Monaten keinerlei Update mit neuen Versionen der Tools gegeben hat.

Da ich länger Kunde der Business-Suite war und eine aktualisierte Version der EMC immer mit erheblichem Verzug erschienen ist, sah ich irgendwann keinen Sinn mehr in der Nutzung.

Aktuell verteile ich die Software entweder per GPO oder über SCCM.

Benutzeravatar
Brigitte (O&O)
Beiträge: 625
Registriert: Mo 27. Jun 2011, 13:06

Re: Lokale Installation über die EMC

Beitrag von Brigitte (O&O) » Fr 6. Mär 2015, 11:05

Hallo th32to,

die neue Version der O&O EMC mit O&O Defrag 18 und DiskImage 9 ist vor wenigen Tagen erschienen. Kunden mit Wartungsvertrag erhalten diese Version automatisch und ohne zusätzliche Kosten.
Brigitte (O&O)

Antworten